DNN Blog 6 Provider

Nov 6, 2013 at 11:52 AM
Im struggling to get the blog provider setup and was hoping you could give me a clue.

Firstly i installed the OpenUrlRewriter_01.00.01_Install.zip for my DNN7.04 install.
second i installed DNNBlog 6.0.1
then on viewing the list of providers under administration screen i dont see the blog provider shown as your demo site does.

Is there a seperate provider download? or is this provider included in the Core?

If its in the core can you tell me what i need to add to the webconfig in the <providers> section, ive tried a few combinations but cant get it to show in the list of providers loaded.
<add name="DNNblogUrlRuleProvider" type="Satrabel.OpenUrlRewriter.Blog.DNNBlogUrlRuleProvider, Satrabel.OpenUrlRewriter.Blog" />
p.s. i was using an older version of this extension and so the install may not have added the all the providers as it would on a fresh install?
Nov 6, 2013 at 4:03 PM
Edited Nov 6, 2013 at 4:05 PM
I've also tried blog 6.0.0 as per the link in providers page in case that was the cause, no different.

Having looked at the source version of OpenUrlRewriter i cant see any mention of Blog so im assuming there is a seperate installer for that provider, but i cant find it anywhere?

Was it removed? Discontinued? Or could i get a copy of the one used on the demo site?

Thanks
Matt
Coordinator
Nov 6, 2013 at 4:07 PM
Edited Nov 6, 2013 at 4:07 PM
Hi, there is actually no official distribution of it.

Here how you can install it :

1) create a directory "OpenUrlRewriter" under "App_Code"

2) Add this file to the new directory

https://dnnblog.codeplex.com/SourceControl/latest#_OpenUrlRewriter/DNNBlogUrlRuleProvider.vb

3) and add this to your web.config
<urlRule defaultProvider="">
      <providers>

...
<add name="blogUrlRuleProvider" type="DNNBlogUrlRuleProvider" />
...
Regards,
Sacha
Marked as answer by sachatrauwaen on 11/11/2013 at 12:00 PM
Nov 7, 2013 at 11:12 AM
Edited Nov 7, 2013 at 3:17 PM
Your a hero, thanks that works.

I'll have to change some of the default templates as the urls are incorrect but the basics are there and the urls are good.

Thanks

Edit: hmm the friendly url part works great, shame the actual blog doesnt work as well :-( Dont Suppose you would consider writing a provider for LiveBlogs ? there is a free trial to work from and naturally would have to buy it to actually use it, but thats ok i dont mind paying for a good feature set that actually works out of the box.
Nov 7, 2013 at 4:32 PM
Just looking at your demo site and noticed it doesnt have comments turned on for the blog example.

Could you turn comments on (only need to be on just long enough to see if comments work on your demo site) as i cant get mine to work and im trying to rule out url rewriting as being the cause....
Coordinator
Nov 7, 2013 at 5:01 PM
Hi,

I have test it

http://openurlrewriter.satrabel.be/en/modules/blog/tip-1-en

It works ok.

Blog version 6.0.0

Regards,
Sacha
Dec 2, 2014 at 11:07 AM
Great, it works for me too :)
Dec 7, 2014 at 6:16 PM
Hi Sacha,

I found a problem, however: if you check this site http://www.energolux-gdfsuez.lu/, the French news work fine, but when you are on the german home and click on a german piece of news you get redirected to the French version. And, when accessing the news from the German side, the German blog post never opens, it always shows just the summary.

I use full localization in the blog settings; I have set the blogs, default and latestposts, as non-detached, is that correct?

Regards

Franco
Coordinator
Dec 7, 2014 at 8:54 PM
Hi,

It's the Blog Team which have developed the open url provider.

I don't know it the blog configuration is ok or not.

First of all you have to look in the open url cache (on the open url module in the admin menu)

and look if you can find the corresponding rule for German.

If you send me a host account at sachatrauwaen [at] yahoo.com i can have a look.

Regards,
Sacha