www.site.com/home/ set to www.site.com/

Jun 22, 2013 at 6:45 PM
Can someone explain how to do this? I've tried many things but still going to /home/
Jun 22, 2013 at 6:49 PM
can it be that in the site settings having home as homepage causes the problem of the redirect not working?
Coordinator
Jun 23, 2013 at 4:50 PM
Hi,

Normally you can create a manual custom redirection from www.site.com/home/ to www.site.com/

The only thing is that actualy the open url rewriter generates all the links to the home page like
www.site.com/home/

Is your site accessible on the internet ?

Regards,
Sacha
Coordinator
Jun 23, 2013 at 4:53 PM
Hi,

This will be managed in next version.

Regards,
Sacha
Jun 24, 2013 at 8:35 PM
Site is still under Development. Can sent by mail of you want.
Coordinator
Jun 27, 2013 at 7:53 PM
Hi,

New version v0.4 is available with RemoveHomePage in the settings of the TabProvider.


Regards,
Sacha
Jun 28, 2013 at 11:29 AM
perfect. Thanx. Just the combination of using useKeyWords and RemoveHomePage are not working together.
so unchecking useKeyWords and checking RemoveHomePage does it for me.

Thanx
Jul 15, 2013 at 8:56 PM
can it be that the latest update changed anything concerning the /home/ to / 301? the removehometab seems not to be functioning anymore.
Coordinator
Jul 16, 2013 at 11:31 AM
Hi,

It's working on me demo site.

Can you check the cache to see if you can find a rule with url=home and NoTab checked and action=rewrite ?

Regards,
Sacha
Jul 17, 2013 at 9:33 AM
Via admin menu I go to urlrewriter.
UseKeyWords is not checked
RemoveHomepage is checked.

The NoTab is not checked.

unchecking and checking removehomepage, using clear, etc doesn't change this.

Type Culture TabId Parameters NoTab Action Url Destination Status
Tab 177 tabid=177 Rewrite home 0


there is 1 thing with no add. info:
components, web.config check
url rewriter and sitemap handler are not green, but yellow/orange warning/info state.
friendly urlprovider and sitemap provider are green.
Coordinator
Jul 17, 2013 at 8:41 PM
Hi,

I just released version 0.4.2 with normally correct your problem.

Let me know if fix your site.

Regards,
Sacha
Jul 17, 2013 at 9:46 PM
unfortunately not.

even if I change in the table OpenUrlRewriter_UrlRule Removetab to true and I clear cache in the module and refresh database
the rule is set back to false.

so resetting the cache sets the rule back to false
Coordinator
Jul 17, 2013 at 9:55 PM
Can you maybe check if the home page is set in the site settings.
Jul 17, 2013 at 10:33 PM
yes it is.

I also tried without home page as start page in site settings.

I have no problems to give you site access, contact me outside the forum if you want :-)

Sander
Coordinator
Jul 18, 2013 at 7:34 AM
Hi,

You can send me site acces at sachatrauwaen [at] yahoo.com

I will have a look.

Regards,
Sacha
Coordinator
Jul 18, 2013 at 12:18 PM
Hi Sander,

I have found the bug :)

I corrected it and installed it on your website.

Regards,
Sacha